| Sign In | Join Free | My entremaqueros.com |
|
| Brand Name: UP | Certification: BSCI,TUV,BV,SGS |
| Model Number: UP-B010 | Minimum Order Quantity: 500pcs |
| Delivery Time: 15-35days | Payment Terms: T/T, L/C, Western Union |
| Xiamen United-Prosperity Industry & Trade Co., Ltd. [Fujian,China] | |
| Verified Supplier | |
| Brand Name: GoodPartner | Certification: AZO REACH CA65 |
| Model Number: NU1911053 | Minimum Order Quantity: 500 PCS |
| Delivery Time: 45 days after approval of the samples | Payment Terms: L/C, T/T, Western Union |
| Xiamen GoodPartner Umbrella Co., Ltd [Fujian,China] | |
| Active Member | |
| Brand Name: GIVEBEST | Certification: CE |
| Model Number: GB-1012 | Minimum Order Quantity: 50pcs |
| Delivery Time: 5-8 days | Payment Terms: L/C, T/T, Western Union, , Paypal |
| Suzhou Givebest Import & Export Co., Ltd [Jiangsu,China] | |
| Active Member | |
| Brand Name: BAGPLASTICS@VIP.163.COM | Certification: ISO 9001:2000, FDA, HACCP, SGS, EN13432 |
| Model Number: WHATSAPP:+8613780964661 | Minimum Order Quantity: 1000pieces Skype: mydearneil |
| Delivery Time: 15 DAYS | Payment Terms: T/T, Western Union |
| YANTAI BAGEASE PRODUCTS SUPPLIES MANUFACTURING CO.,LTD. [China] | |
| Site Member | |
| Brand Name: HIFINE | Model Number: HFU-602 |
| Minimum Order Quantity: 300 | general use: Outdoor Furniture |
| Material: Other | mail packing: Y |
| jiaxing hifine international enterprise co ltd [Zhejiang,China] | |
| Verified Supplier | |
| Minimum Order Quantity: 2 pieces | Price: US$99 |
| Foshan Yoshen Outdoor Furnishing Co.,Ltd [Guangdong,China] | |
| Site Member | |
| Brand Name: Roman Umbrella | Certification: CE,ISO,SGS |
| Model Number: Roman Umbrella | Minimum Order Quantity: 1 |
| Delivery Time: 1-15 work days | Payment Terms: L/C,D/A,D/P,T/T,Western Union |
| Guangdong Aikeli Intelligent Technology Co., Ltd. [Guangdong,China] | |
| Verified Supplier | |
| Brand Name: GRH | Model Number: GRH-E001,GRH-RFC1004,GRH-RFC1005,GRH-RFC1011 |
| Minimum Order Quantity: 1000 PCS | Delivery Time: 20 days to 50 days after received the deposit. |
| Payment Terms: L/C, T/T, Western Union, D/P | Place of Origin: CHINA |
| WENZHOU GRH MANUFACTURE CO.,LTD [Zhejiang,China] | |
| Verified Supplier | |
| Brand Name: YLF | Model Number: YLF |
| Minimum Order Quantity: 500 | Payment Terms: T/T |
| Type: Umbrellas | Product: Advertising Umbrella/Gift Umbrella |
| Jinjiang YLF Umbrella Co., Ltd. [Fujian,China] | |
| Verified Supplier | |
| Model Number: AJ-GU-016 | Minimum Order Quantity: 100 pieces |
| General Use: Outdoor Furniture | Mail packing: Y |
| Application: Outdoor, Hotel, Leisure Facilities, Park, Courtyard, Villa | Design Style: Modern |
| Ningbo Aj Union Imp.& Exp. Co., Ltd. [Zhejiang,China] | |
| Verified Supplier | |
| Brand Name: Changsheng | Model Number: CS047 |
| Minimum Order Quantity: 2 sets | General Use: Outdoor Furniture, Outdoor FurnitureOutdoor Furniture |
| Mail packing: N | Application: Outdoor, Hotel, Apartment, Office Building, Leisure ... |
| Foshan Woderful furniture Co., Ltd. [Guangdong,China] | |
| Verified Supplier | |
| Brand Name: FULL | Certification: BSCI, SGS |
| Model Number: FAN-038 | Minimum Order Quantity: 500pcs |
| Delivery Time: 30 days | Payment Terms: Western Union,T/T,L/C |
| Shenzhen Fxinda Umbrella Company Limited [Guangdong,China] | |
| Verified Supplier | |
| Brand Name: WINTOP | Certification: EN71, REACH, AZO FREE, UPF ANTI UV50+ |
| Model Number: WTG026 | Minimum Order Quantity: 3600PCS |
| Delivery Time: 50-60 days | Payment Terms: T/T, L/C |
| XIAMEN WINTOP IMP. AND EXP. CO., LTD [Fujian,China] | |
| Active Member | |
| Certification: BSCI, EN581 | Model Number: 1151.130 |
| Minimum Order Quantity: 500pcs | Delivery Time: 30 days |
| Payment Terms: L/C, T/T | Place of Origin: China |
| Ningbo Walkingworld Leisure Products Co.,Ltd [Zhejiang,China] | |
| Active Member | |
| Brand Name: TOKO | Certification: WCA |
| Model Number: MN009 | Minimum Order Quantity: 500pcs |
| Delivery Time: 55 days | Place of Origin: China |
| Xiamen Toko Umbrella Co.,Ltd. [Fujian,China] | |
| Active Member | |
| Brand Name: Neutral | Certification: ISO9001, BSCI |
| Model Number: DZY-M0002 | Minimum Order Quantity: 300pcs |
| Delivery Time: 15~30days | Payment Terms: T/T, PayPal |
| DNJ Trading (Shenzhen) Co., Ltd. [Guangdong,China] | |
| Active Member | |
| Brand Name: HAFE | Certification: / |
| Model Number: TM11 Series | Minimum Order Quantity: 1unit |
| Delivery Time: 7-10 days(depends on specific units) | Payment Terms: T/T, Paypal, Western Union |
| Hafe International Limited [Hong Kong,China] | |
| Verified Supplier | |
| Model Number: BLIU05 | Minimum Order Quantity: 500 pieces |
| Type: Umbrellas | Product: Umbrella |
| Function: All in 1 | Pattern: Straight Umbrella |
| Yuyao Believe Leisure Products Co., Ltd. [Zhejiang,China] | |
| Verified Supplier | |